#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(Lord|Lady|Ser)[ ](?:(Agatha|John)?(?:[ ](Cain))?)|(Agatha|John|Cain)\b"
Local $sString = "Lord John Cain asked..." & @CRLF & _
"Ser John has..." & @CRLF & _
"Inside the castle, Lord Cain was speaking with Lady Cain." & @CRLF & _
"John was eating." & @CRLF & _
"He looked at them. Cain was walking..." & @CRLF & _
"The castle of Cain is..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")