re = /\b(Lord|Lady|Ser)[ ](?:(Agatha|John)?(?:[ ](Cain))?)|(Agatha|John|Cain)\b/
str = 'Lord John Cain asked...
Ser John has...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating.
He looked at them. Cain was walking...
The castle of Cain is...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end