import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(Lord|Lady|Ser)[ ](?:(Agatha|John)?(?:[ ](Cain))?)|(Agatha|John|Cain)\\b";
final String string = "Lord John Cain asked...\n"
+ "Ser John has...\n"
+ "Inside the castle, Lord Cain was speaking with Lady Cain.\n"
+ "John was eating.\n"
+ "He looked at them. Cain was walking...\n"
+ "The castle of Cain is...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}