# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\[([^\|\]]*)(?:\||.*\]\])//m;t' <<< "[[Kapellmeister]]
[[Erschallet, ihr Lieder, erklinget, ihr Saiten! BWV 172|\'\'Erschallet, ihr Lieder, erklinget, ihr Saiten!\'\' BWV 172]]
"