const regex = /\[\[([^\|\]]*)(?:\||.*\]\])/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[([^\\|\\]]*)(?:\\||.*\\]\\])', 'm')
const str = `[[Kapellmeister]]
[[Erschallet, ihr Lieder, erklinget, ihr Saiten! BWV 172|\\'\\'Erschallet, ihr Lieder, erklinget, ihr Saiten!\\'\\' BWV 172]]
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);