$re = '/\[\[([^\|\]]*)(?:\||.*\]\])/m';
$str = '[[Kapellmeister]]
[[Erschallet, ihr Lieder, erklinget, ihr Saiten! BWV 172|\\\'\\\'Erschallet, ihr Lieder, erklinget, ihr Saiten!\\\'\\\' BWV 172]]
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;