#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\[([^\|\]]*)(?:\||.*\]\])"
Local $sString = "[[Kapellmeister]]" & @CRLF & _
"[[Erschallet, ihr Lieder, erklinget, ihr Saiten! BWV 172|\'\'Erschallet, ihr Lieder, erklinget, ihr Saiten!\'\' BWV 172]]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)