re = /\.(\w*)$/
str = 'http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg'
subst = '-150x150.$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result