using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^""]);";
string substitution = @"";
string input = @"""Value1"";0;""Value2"";4711;""Evil; Value"";""2015-09-03""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}