use strict;
my $str = '"Value1";0;"Value2";4711;"Evil; Value";"2015-09-03"';
my $regex = qr/(?<=[^"]);/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";