using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(assert\(\s*)'(.+)'(\s*\);)";
string substitution = @"\1\2\3";
string input = @"assert( 'isNonEmptyString( $string )' );
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}