const regex = /(assert\(\s*)'(.+)'(\s*\);)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(assert\\(\\s*)\'(.+)\'(\\s*\\);)', 'gm')
const str = `assert( 'isNonEmptyString( \$string )' );
`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);