import re
regex = re.compile(r"(assert\(\s*)'(.+)'(\s*\);)", flags=re.MULTILINE)
test_str = ("assert( 'isNonEmptyString( $string )' );\n")
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)