re = /(assert\(\s*)'(.+)'(\s*\);)/m
str = 'assert( \'isNonEmptyString( $string )\' );
'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result