using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([^|]+?)\s+\|[^|]+$";
string input = @"Brand Name A | Book now
Brand Name B | Order here
Content | Brand Name A | Order now
Content | Brand Name 7 | Click here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}