package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([^|]+?)\s+\|[^|]+$`)
var str = `Brand Name A | Book now
Brand Name B | Order here
Content | Brand Name A | Order now
Content | Brand Name 7 | Click here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}