// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*([^|]+?)\s+\|[^|]+$").unwrap();
let string = "Brand Name A | Book now
Brand Name B | Order here
Content | Brand Name A | Order now
Content | Brand Name 7 | Click here";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}