$re = '/\s*([^|]+?)\s+\|[^|]+$/m';
$str = 'Brand Name A | Book now
Brand Name B | Order here
Content | Brand Name A | Order now
Content | Brand Name 7 | Click here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);