using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""hours"":\s*(\{(?>[^{}]++|(?1))*\})";
string input = @"""hours"": {""Monday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Tuesday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Friday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Wednesday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Thursday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Sunday"": {""close"": ""18:00"", ""open"": ""11:00""}, ""Saturday"": {""close"": ""19:00"", ""open"": ""10:00""}}
{""storeid: ""Hsdf34"", ""hours"": {""Monday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Tuesday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Friday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Wednesday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Thursday"": {""close"": ""19:00"", ""open"": ""10:00""}, ""Sunday"": {""close"": ""18:00"", ""open"": ""11:00""}, ""Saturday"": {""close"": ""19:00"", ""open"": ""10:00""}}, ""address"": ""1234 Sunset Avenue""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}