re = /"hours":\s*(\{(?>[^{}]++|(?1))*\})/
str = '"hours": {"Monday": {"close": "19:00", "open": "10:00"}, "Tuesday": {"close": "19:00", "open": "10:00"}, "Friday": {"close": "19:00", "open": "10:00"}, "Wednesday": {"close": "19:00", "open": "10:00"}, "Thursday": {"close": "19:00", "open": "10:00"}, "Sunday": {"close": "18:00", "open": "11:00"}, "Saturday": {"close": "19:00", "open": "10:00"}}
{"storeid: "Hsdf34", "hours": {"Monday": {"close": "19:00", "open": "10:00"}, "Tuesday": {"close": "19:00", "open": "10:00"}, "Friday": {"close": "19:00", "open": "10:00"}, "Wednesday": {"close": "19:00", "open": "10:00"}, "Thursday": {"close": "19:00", "open": "10:00"}, "Sunday": {"close": "18:00", "open": "11:00"}, "Saturday": {"close": "19:00", "open": "10:00"}}, "address": "1234 Sunset Avenue"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end