import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"hours\":\\s*(\\{(?>[^\\{\\}]++|(?1))*\\})";
final String string = "\"hours\": {\"Monday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Tuesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Friday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Wednesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Thursday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Sunday\": {\"close\": \"18:00\", \"open\": \"11:00\"}, \"Saturday\": {\"close\": \"19:00\", \"open\": \"10:00\"}}\n"
+ "{\"storeid: \"Hsdf34\", \"hours\": {\"Monday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Tuesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Friday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Wednesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Thursday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Sunday\": {\"close\": \"18:00\", \"open\": \"11:00\"}, \"Saturday\": {\"close\": \"19:00\", \"open\": \"10:00\"}}, \"address\": \"1234 Sunset Avenue\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}