#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1,3}(?:[.,]\d{3})*(?:[.,]\d{2})"
Local $sString = "5" & @CRLF & _
"5.00" & @CRLF & _
"1,000" & @CRLF & _
"1,000,000.99" & @CRLF & _
"5,99 (european price)" & @CRLF & _
"5.999,99 (european price)" & @CRLF & _
"0.11" & @CRLF & _
"0.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")