re = /\d{1,3}(?:[.,]\d{3})*(?:[.,]\d{2})/
str = '5
5.00
1,000
1,000,000.99
5,99 (european price)
5.999,99 (european price)
0.11
0.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end