package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,3}(?:[.,]\d{3})*(?:[.,]\d{2})`)
var str = `5
5.00
1,000
1,000,000.99
5,99 (european price)
5.999,99 (european price)
0.11
0.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}