#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s+$"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"General Information" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Brand: " & @CRLF & _
" Whirlpool " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Model name: " & @CRLF & _
" PACW9HP " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Type: " & @CRLF & _
" On/Off " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Construction Type: " & @CRLF & _
" Free-Standing " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Number of Speeds: " & @CRLF & _
" 7 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Mode" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Cooling: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Heating: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Antibacterial Filters: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Ionization: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Sleep Function: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Conditioner Features" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Recommended Area: " & @CRLF & _
" 25 - 30 m² " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Capacity Cooling (BTU): " & @CRLF & _
" 9000 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Capacity Heating (BTU): " & @CRLF & _
" 8500 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Capacity Cooling (W): " & @CRLF & _
" 3000 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Capacity Heating (W): " & @CRLF & _
" 2000 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Air Flow: " & @CRLF & _
" 350 m³/h " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Indoor Noise Level: " & @CRLF & _
" 65 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" HEPA Filter: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Compressor" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Refrigerant: " & @CRLF & _
" R410A " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Type of Compressor: " & @CRLF & _
" Rotary " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Energy Rating" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Energy Efficiency Class: " & @CRLF & _
" A+ " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Remote Control" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Remote Control: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Timer on / off: " & @CRLF & _
" Yes " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Power" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Power from: " & @CRLF & _
" Network " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Voltage: " & @CRLF & _
" 200-240 V " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Cord Length: " & @CRLF & _
" 1.2 m " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Color" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Color: " & @CRLF & _
" White " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Dimensions" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Dimensions (W x H x D): " & @CRLF & _
" 448 x 743 x 400 mm " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Weight" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Weight: " & @CRLF & _
" 31 kg " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Warranty" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" Warranty: " & @CRLF & _
" 36 Months " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")