// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s+$").unwrap();
let string = "
General Information
Brand:
Whirlpool
Model name:
PACW9HP
Type:
On/Off
Construction Type:
Free-Standing
Number of Speeds:
7
Mode
Cooling:
Yes
Heating:
Yes
Antibacterial Filters:
Yes
Ionization:
Yes
Sleep Function:
Yes
Conditioner Features
Recommended Area:
25 - 30 m²
Capacity Cooling (BTU):
9000
Capacity Heating (BTU):
8500
Capacity Cooling (W):
3000
Capacity Heating (W):
2000
Air Flow:
350 m³/h
Indoor Noise Level:
65
HEPA Filter:
Yes
Compressor
Refrigerant:
R410A
Type of Compressor:
Rotary
Energy Rating
Energy Efficiency Class:
A+
Remote Control
Remote Control:
Yes
Timer on / off:
Yes
Power
Power from:
Network
Voltage:
200-240 V
Cord Length:
1.2 m
Color
Color:
White
Dimensions
Dimensions (W x H x D):
448 x 743 x 400 mm
Weight
Weight:
31 kg
Warranty
Warranty:
36 Months
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}