import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+$";
final String string = "\n"
+ " \n"
+ " \n"
+ "General Information\n"
+ " \n"
+ " \n"
+ " Brand: \n"
+ " Whirlpool \n"
+ " \n"
+ " \n"
+ " Model name: \n"
+ " PACW9HP \n"
+ " \n"
+ " \n"
+ " Type: \n"
+ " On/Off \n"
+ " \n"
+ " \n"
+ " Construction Type: \n"
+ " Free-Standing \n"
+ " \n"
+ " \n"
+ " Number of Speeds: \n"
+ " 7 \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Mode\n"
+ " \n"
+ " \n"
+ " Cooling: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " Heating: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " Antibacterial Filters: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " Ionization: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " Sleep Function: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Conditioner Features\n"
+ " \n"
+ " \n"
+ " Recommended Area: \n"
+ " 25 - 30 m² \n"
+ " \n"
+ " \n"
+ " Capacity Cooling (BTU): \n"
+ " 9000 \n"
+ " \n"
+ " \n"
+ " Capacity Heating (BTU): \n"
+ " 8500 \n"
+ " \n"
+ " \n"
+ " Capacity Cooling (W): \n"
+ " 3000 \n"
+ " \n"
+ " \n"
+ " Capacity Heating (W): \n"
+ " 2000 \n"
+ " \n"
+ " \n"
+ " Air Flow: \n"
+ " 350 m³/h \n"
+ " \n"
+ " \n"
+ " Indoor Noise Level: \n"
+ " 65 \n"
+ " \n"
+ " \n"
+ " HEPA Filter: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Compressor\n"
+ " \n"
+ " \n"
+ " Refrigerant: \n"
+ " R410A \n"
+ " \n"
+ " \n"
+ " Type of Compressor: \n"
+ " Rotary \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Energy Rating\n"
+ " \n"
+ " \n"
+ " Energy Efficiency Class: \n"
+ " A+ \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Remote Control\n"
+ " \n"
+ " \n"
+ " Remote Control: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " Timer on / off: \n"
+ " Yes \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Power\n"
+ " \n"
+ " \n"
+ " Power from: \n"
+ " Network \n"
+ " \n"
+ " \n"
+ " Voltage: \n"
+ " 200-240 V \n"
+ " \n"
+ " \n"
+ " Cord Length: \n"
+ " 1.2 m \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Color\n"
+ " \n"
+ " \n"
+ " Color: \n"
+ " White \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Dimensions\n"
+ " \n"
+ " \n"
+ " Dimensions (W x H x D): \n"
+ " 448 x 743 x 400 mm \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Weight\n"
+ " \n"
+ " \n"
+ " Weight: \n"
+ " 31 kg \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Warranty\n"
+ " \n"
+ " \n"
+ " Warranty: \n"
+ " 36 Months \n"
+ " \n"
+ " \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}