# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s+$"
test_str = ("\n"
" \n"
" \n"
"General Information\n"
" \n"
" \n"
" Brand: \n"
" Whirlpool \n"
" \n"
" \n"
" Model name: \n"
" PACW9HP \n"
" \n"
" \n"
" Type: \n"
" On/Off \n"
" \n"
" \n"
" Construction Type: \n"
" Free-Standing \n"
" \n"
" \n"
" Number of Speeds: \n"
" 7 \n"
" \n"
" \n"
" \n"
" \n"
"Mode\n"
" \n"
" \n"
" Cooling: \n"
" Yes \n"
" \n"
" \n"
" Heating: \n"
" Yes \n"
" \n"
" \n"
" Antibacterial Filters: \n"
" Yes \n"
" \n"
" \n"
" Ionization: \n"
" Yes \n"
" \n"
" \n"
" Sleep Function: \n"
" Yes \n"
" \n"
" \n"
" \n"
" \n"
"Conditioner Features\n"
" \n"
" \n"
" Recommended Area: \n"
" 25 - 30 m² \n"
" \n"
" \n"
" Capacity Cooling (BTU): \n"
" 9000 \n"
" \n"
" \n"
" Capacity Heating (BTU): \n"
" 8500 \n"
" \n"
" \n"
" Capacity Cooling (W): \n"
" 3000 \n"
" \n"
" \n"
" Capacity Heating (W): \n"
" 2000 \n"
" \n"
" \n"
" Air Flow: \n"
" 350 m³/h \n"
" \n"
" \n"
" Indoor Noise Level: \n"
" 65 \n"
" \n"
" \n"
" HEPA Filter: \n"
" Yes \n"
" \n"
" \n"
" \n"
" \n"
"Compressor\n"
" \n"
" \n"
" Refrigerant: \n"
" R410A \n"
" \n"
" \n"
" Type of Compressor: \n"
" Rotary \n"
" \n"
" \n"
" \n"
" \n"
"Energy Rating\n"
" \n"
" \n"
" Energy Efficiency Class: \n"
" A+ \n"
" \n"
" \n"
" \n"
" \n"
"Remote Control\n"
" \n"
" \n"
" Remote Control: \n"
" Yes \n"
" \n"
" \n"
" Timer on / off: \n"
" Yes \n"
" \n"
" \n"
" \n"
" \n"
"Power\n"
" \n"
" \n"
" Power from: \n"
" Network \n"
" \n"
" \n"
" Voltage: \n"
" 200-240 V \n"
" \n"
" \n"
" Cord Length: \n"
" 1.2 m \n"
" \n"
" \n"
" \n"
" \n"
"Color\n"
" \n"
" \n"
" Color: \n"
" White \n"
" \n"
" \n"
" \n"
" \n"
"Dimensions\n"
" \n"
" \n"
" Dimensions (W x H x D): \n"
" 448 x 743 x 400 mm \n"
" \n"
" \n"
" \n"
" \n"
"Weight\n"
" \n"
" \n"
" Weight: \n"
" 31 kg \n"
" \n"
" \n"
" \n"
" \n"
"Warranty\n"
" \n"
" \n"
" Warranty: \n"
" 36 Months \n"
" \n"
" \n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.