using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)((\byo\b.*?(cut me:).*))$";
string input = @"Hi
yo keep this here
Keep this here
yo
key match line here cut me:
All of this here should be deleted";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}