package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^(.*)((\byo\b.*?(cut me:).*))$`)
var str = `Hi
yo keep this here
Keep this here
yo
key match line here cut me:
All of this here should be deleted`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}