re = /^(.*)((\byo\b.*?(cut me:).*))$/m
str = 'Hi
yo keep this here
Keep this here
yo
key match line here cut me:
All of this here should be deleted'
# Print the match result
str.match(re) do |match|
puts match.to_s
end