re = /\b\d{1,3}(?:\.\d{1,3}){3}(?:\/[^"]+)?/
str = '"1.2.3.4/1.0", "1.2.3.4/a", "10.0.2.3/1"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end