// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\b\d{1,3}(?:\.\d{1,3}){3}(?:/[^"]+)?"#).unwrap();
let string = "\"1.2.3.4/1.0\", \"1.2.3.4/a\", \"10.0.2.3/1\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}