package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\/\/[^\n]+`)
var str = `function session(){
return 1; // this default value for session
just more code
again, more code with a comment // this is another comment
return false;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}