import re
regex = re.compile(r"\s+\/\/[^\n]+", flags=re.MULTILINE)
test_str = ("function session(){\n"
" return 1; // this default value for session\n"
" just more code\n"
" again, more code with a comment // this is another comment\n"
" return false;\n"
" \n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")