// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+\/\/[^\n]+").unwrap();
let string = "function session(){
return 1; // this default value for session
just more code
again, more code with a comment // this is another comment
return false;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}