re = /\s+\/\/[^\n]+/m
str = 'function session(){
return 1; // this default value for session
just more code
again, more code with a comment // this is another comment
return false;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end