use strict;
my $str = '01/23/16 -22 32- 34- 40- 69 PB 19 X4';
my $regex = qr/(\d\d\/\d\d\/\d\d)\s+-(\d+)\s+(\d+)-\s+(\d+)-\s+(\d+)-\s+(\d+)\s+PB\s+(\d+)\s+(X\d+)/p;
my $subst = '$2 $3 $4 $5 $6 $7';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";