$re = '/(\d\d\/\d\d\/\d\d)\s+-(\d+)\s+(\d+)-\s+(\d+)-\s+(\d+)-\s+(\d+)\s+PB\s+(\d+)\s+(X\d+)/';
$str = '01/23/16 -22 32- 34- 40- 69 PB 19 X4';
$subst = "$2 $3 $4 $5 $6 $7";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;