// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d\d\/\d\d\/\d\d)\s+-(\d+)\s+(\d+)-\s+(\d+)-\s+(\d+)-\s+(\d+)\s+PB\s+(\d+)\s+(X\d+)").unwrap();
let string = "01/23/16 -22 32- 34- 40- 69 PB 19 X4";
let substitution = "$2 $3 $4 $5 $6 $7";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}