package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:https?:)?\/\/(?:[\w]+[.][\w]+)+/?)+$`)
var str = `http://hk.jkkj.jkk.bjjj
http://hhhcom/
//llklklkl.com
uyiyiiy
((?:https?:)?\/\/[\w\.\-]+/?)+$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}