$re = '/((?:https?:)?\/\/(?:[\w]+[.][\w]+)+/?)+$/m';
$str = 'http://hk.jkkj.jkk.bjjj
http://hhhcom/
//llklklkl.com
uyiyiiy
((?:https?:)?\\/\\/[\\w\\.\\-]+/?)+$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);