re = /((?:https?:)?\/\/(?:[\w]+[.][\w]+)+\/?)+$/m
str = 'http://hk.jkkj.jkk.bjjj
http://hhhcom/
//llklklkl.com
uyiyiiy
((?:https?:)?\\/\\/[\\w\\.\\-]+/?)+$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end