using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+\s+\d+\s+\S+)\s*\S*\s*\S*\s*(Failed authentication attempt)\s+\S+\s+\S+\ IP: (\S*)";
string input = @"Feb 19 15:02:04 domain.ru:log_auth warn Failed authentication attempt (not-authorized) from IP: 1.2.3.4";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}