const regex = /^(\S+\s+\d+\s+\S+)\s*\S*\s*\S*\s*(Failed authentication attempt)\s+\S+\s+\S+\ IP: (\S*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+\\s+\\d+\\s+\\S+)\\s*\\S*\\s*\\S*\\s*(Failed authentication attempt)\\s+\\S+\\s+\\S+\\ IP: (\\S*)', '')
const str = `Feb 19 15:02:04 domain.ru:log_auth warn Failed authentication attempt (not-authorized) from IP: 1.2.3.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}