re = /^(\S+\s+\d+\s+\S+)\s*\S*\s*\S*\s*(Failed authentication attempt)\s+\S+\s+\S+\ IP: (\S*)/
str = 'Feb 19 15:02:04 domain.ru:log_auth warn Failed authentication attempt (not-authorized) from IP: 1.2.3.4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end