import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\bwww.deindesign.de\\/de\\/designer\\b.*?\\workspace\\b.*?$";
final String string = "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162674402\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/house/101149226/162674402\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/peter/101149226/162674402\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162688402\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732168/\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732163/\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/1626884032\n"
+ "https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732162/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}