import re
regex = re.compile(r"^.*?\bwww.deindesign.de\/de\/designer\b.*?\workspace\b.*?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162674402\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/house/101149226/162674402\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/peter/101149226/162674402\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162688402\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732168/\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732163/\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/1626884032\n"
"https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732162/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")