re = /^.*?\bwww.deindesign.de\/de\/designer\b.*?\workspace\b.*?$/mi
str = 'https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/house/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/peter/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162688402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732168/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732163/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/1626884032
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732162/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end