using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w*\s*-\s*\w*\b";
string input = @"word1-word2
asdfsf sf word1-word2 sdf sdf
word1 - word2
word1 word2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}